Service Interruption
Incident Report for CATS Software, Inc.
Resolved
This incident has been resolved. We apologize for any inconvenience.
Posted Oct 03, 2023 - 13:21 CDT
Investigating
We are currently investigating the interruption in service. Check back for updates shortly.
Posted Oct 03, 2023 - 13:05 CDT
This incident affected: CATS.