Intermittent Career Portal outage
Incident Report for CATS Software, Inc.
Resolved
This incident has been resolved.
Posted May 14, 2024 - 06:26 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 14, 2024 - 06:24 CDT
Investigating
We are currently investigating an issue affecting some Career Portals. We will update this page once we have identified a fix.
Posted May 14, 2024 - 06:07 CDT
This incident affected: Career Portal.