Career Portal outage
Incident Report for CATS Software, Inc.
Resolved
This incident has been resolved. We apologize for any inconvenience.
Posted Jan 17, 2024 - 05:39 CST
Investigating
We are currently investigating an issue with the Career Portal. We will update this page as soon as we've identified the cause of the outage and are implementing a fix.
Posted Jan 17, 2024 - 03:47 CST
This incident affected: Career Portal.